Teen Programmers Unite  


Return to forum top

Connecting to the Internet with Linux [Help!]

Posted by FatalDragon [send private reply] at September 02, 2002, 09:39:21 PM

Im trying to connect Red Hat 7.0 to the Internet. I'v been using the Red Hat's PPP configuration program. I'm pretty sure I gave it all the correct information. When I click debug, it gives me a message saying "/dev/ttyS0 input output problem" or something like that. When I first started up PPP configuration program it scanned for a modem, and that's what [ttyS0] it found. But when I installed Red Hat it asked where my modem was, and I said ttyS0 because I didnt know where the modem was. Any ideas? How can I find out where my modem is? ThanX!

Posted by FatalDragon [send private reply] at September 02, 2002, 10:28:31 PM

Well, I changed the modem to ttyS1 [infact I tried ttyS2, and ttyS3, but got the same results as with ttyS0, so Im thinking that ttyS1 is the modem], and it claims that it's trying to dial, but I still get a error saying modem could not be intialized.

Posted by buzgub [send private reply] at September 03, 2002, 12:10:01 AM

What are the permissions on /dev/ttyS0? The command "ls -l /dev/ttys0" should tell you.

Posted by FatalDragon [send private reply] at September 03, 2002, 06:20:41 PM

Nope, it's not the permissions. I think it's because I have a WinModem. It has "Lucent" on the chips, and IBM's tech archive said it has a "K56 Flex" modem. I found some drivers for Lucent modems, but I haven't tried them yet. I'll let you all know the link if they work.

You must be logged in to post messages and see which you have already read.

Log on
Save for later automatic logon

Register as a new user
Copyright TPU 2002. See the Credits and About TPU for more information.