Teen Programmers Unite  


Return to forum top

Veiwing web pages from a Linux user account, help please

Posted by ItinitI [send private reply] at December 20, 2002, 05:16:06 PM

Okee, I got my Slackware Linux set up, modem included, and The modem works. So, I can dial up to my ISP as either root or a user, but when I'm in a user account I can't veiw web pages, I'v tried in both Konquer, Netscape, and it won't even let AIM or IRC conect to their servers. But, when I'm useing root account it lets me veiw web pages. So why is it doing this, and how can I give my user acount the ability to view web pages???

I gave all users access for ttyS0/modem and port, being I thought it might be that user didn't have root privs but that didn't help any.

Please help, I think maybe it's has something to do with fire wall or some thing, I dunno. (>_<)
Very ThanX!

Posted by taubz [send private reply] at December 20, 2002, 08:14:20 PM

Obviously you chose the wrong distro. :)

Try running:

telnet tpu.org 80
from a prompt (type a few [enter]'s if connects successfully). If the connection fails, post here what error message you got. (Port 80 is the port used for http.)

- taubz
Posted by ItinitI [send private reply] at December 20, 2002, 09:01:46 PM

Slackware, wrong distro??

Any way, after I told it that [telnet tpu.org 80], it responded:

'tpu.org: Host name lookup failure'

It says things like that on Konquer [Host Uknown], and Netscape also.

Any ideas? I'm thinking some kinda permissions deal, but don't know.

Posted by gian [send private reply] at December 20, 2002, 09:24:22 PM

Are your DNS servers configured correctly?

Posted by ItinitI [send private reply] at December 20, 2002, 09:34:59 PM

Eh? Elaborate, please. It's simply a dial up, no networks, or broad band.

Posted by Qubit [send private reply] at December 21, 2002, 12:48:21 AM

you need to ensure your /etc/resolv.conf has something like this:

of course, those IP numbers are for your ISP's DNS servers. They WILL
be different unless you happen to use AT&T.

what did you run to setup dialup? pppsetup? or some crazy kde dialup app?

if it was KDE it could potentially store that information elsewhere nonstandard.

get standard and run pppsetup at the command prompt. there are howtos and docs
everywhere on dialup. check out www.linuxdocs.org or somesuch.


Posted by ItinitI [send private reply] at December 21, 2002, 12:50:43 PM

Eh, well, a re install seems to have done the job.

But, yeah, I ran pppsetup first, it didn't work, then I ran kpp and it said 'sorry, the modem is busy' so I searched around and found to turn off PnP in the bios, did that and both kppp and pppsetup work. Until I got this prob, but like I said the re install seemed to work.

Very ThanX!

You must be logged in to post messages and see which you have already read.

Log on
Save for later automatic logon

Register as a new user
Copyright TPU 2002. See the Credits and About TPU for more information.